تبدیل فایل پایتون به apk

سوال

من برنامه رو با فرمورک کیوی پایتون نوشتم و الان میخوام تبدیل به apk کنم و یک پوشه همراه داره که داخل فونت و امیج های به کار رفته در برنامه است و میخوام توی این سایت چجوری با پوشه همراه و فایل کد تبدیل به apk کنم ادرس سایت :https://colab.research.google.com/gi…o=tLbircO10N0a و وقتی میخوام تبدیل کنم یک این ارور رو هنگام تبدیل میده
[COLOR=var(–ansi-red)]# Command failed: [‘/usr/bin/python3’, ‘-m’, ‘pythonforandroid.toolchain’, ‘create’, ‘–dist_name=myapp’, ‘–bootstrap=sdl2’, ‘–requirements=python3,kivy’, ‘–arch=arm64-v8a’, ‘–arch=armeabi-v7a’, ‘–copy-libs’, ‘–color=always’, ‘–storage-dir=/content/.buildozer/android/platform/build-arm64-v8a_armeabi-v7a’, ‘–ndk-api=21’, ‘–ignore-setup-py’, ‘–debug’][/COLOR]
[COLOR=var(–ansi-red)]# ENVIRONMENT:[/COLOR]
[COLOR=var(–ansi-red)]# SHELL = ‘/bin/bash’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_VERSION = ‘11.11.3.6-1’[/COLOR]
[COLOR=var(–ansi-red)]# NVIDIA_VISIBLE_DEVICES = ‘all’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_JUPYTER_TRANSPORT = ‘ipc’[/COLOR]
[COLOR=var(–ansi-red)]# NV_NVML_DEV_VERSION = ‘11.8.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDNN_PACKAGE_NAME = ‘libcudnn8’[/COLOR]
[COLOR=var(–ansi-red)]# CGROUP_MEMORY_EVENTS = ‘/sys/fs/cgroup/memory.events /var/colab/cgroup/jupyter-children/memory.events’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_DEV_PACKAGE = ‘libnccl-dev=2.15.5-1+cuda11.8’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_DEV_PACKAGE_VERSION = ‘2.15.5-1’[/COLOR]
[COLOR=var(–ansi-red)]# VM_GCE_METADATA_HOST = ‘169.254.169.253’[/COLOR]
[COLOR=var(–ansi-red)]# HOSTNAME = ‘d67fd118af23’[/COLOR]
[COLOR=var(–ansi-red)]# LANGUAGE = ‘en_US’[/COLOR]
[COLOR=var(–ansi-red)]# TBE_RUNTIME_ADDR = ‘172.28.0.1:8011’[/COLOR]
[COLOR=var(–ansi-red)]# GCE_METADATA_TIMEOUT = ‘3’[/COLOR]
[COLOR=var(–ansi-red)]# NVIDIA_REQUIRE_CUDA = (‘cuda>=11.8 brand=tesla,driver>=450,driver<451 ‘
‘brand=tesla,driver>=470,driver<471 brand=unknown,driver>=470,driver<471 ‘
‘brand=nvidia,driver>=470,driver<471 brand=nvidiartx,driver>=470,driver<471 ‘
‘brand=geforce,driver>=470,driver<471 brand=geforcertx,driver>=470,driver<471 ‘
‘brand=quadro,driver>=470,driver<471 brand=quadrortx,driver>=470,driver<471 ‘
‘brand=titan,driver>=470,driver<471 brand=titanrtx,driver>=470,driver<471 ‘
‘brand=tesla,driver>=510,driver<511 brand=unknown,driver>=510,driver<511 ‘
‘brand=nvidia,driver>=510,driver<511 brand=nvidiartx,driver>=510,driver<511 ‘
‘brand=geforce,driver>=510,driver<511 brand=geforcertx,driver>=510,driver<511 ‘
‘brand=quadro,driver>=510,driver<511 brand=quadrortx,driver>=510,driver<511 ‘
‘brand=titan,driver>=510,driver<511 brand=titanrtx,driver>=510,driver<511 ‘
‘brand=tesla,driver>=515,driver<516 brand=unknown,driver>=515,driver<516 ‘
‘brand=nvidia,driver>=515,driver<516 brand=nvidiartx,driver>=515,driver<516 ‘
‘brand=geforce,driver>=515,driver<516 brand=geforcertx,driver>=515,driver<516 ‘
‘brand=quadro,driver>=515,driver<516 brand=quadrortx,driver>=515,driver<516 ‘
‘brand=titan,driver>=515,driver<516 brand=titanrtx,driver>=515,driver<516’)
[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_DEV_PACKAGE = ‘libcublas-dev-11-8=11.11.3.6-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_NVTX_VERSION = ‘11.8.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_JUPYTER_IP = ‘172.28.0.12’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_CUDART_DEV_VERSION = ‘11.8.89-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUSPARSE_VERSION = ‘11.7.5.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_LANGUAGE_SERVER_PROXY_ROOT_URL = ‘http://172.28.0.1:8013/[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNPP_VERSION = ‘11.8.0.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# NCCL_VERSION = ‘2.15.5-1’[/COLOR]
[COLOR=var(–ansi-red)]# KMP_LISTEN_PORT = ‘6000’[/COLOR]
[COLOR=var(–ansi-red)]# TF_FORCE_GPU_ALLOW_GROWTH = ‘true’[/COLOR]
[COLOR=var(–ansi-red)]# ENV = ‘/root/.bashrc’[/COLOR]
[COLOR=var(–ansi-red)]# PWD = ‘/content’[/COLOR]
[COLOR=var(–ansi-red)]# TBE_EPHEM_CREDS_ADDR = ‘172.28.0.1:8009’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_LANGUAGE_SERVER_PROXY_REQUEST_TIMEOUT = ’30s’[/COLOR]
[COLOR=var(–ansi-red)]# TBE_CREDS_ADDR = ‘172.28.0.1:8008’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDNN_PACKAGE = ‘libcudnn8=8.9.0.131-1+cuda11.8’[/COLOR]
[COLOR=var(–ansi-red)]# NVIDIA_DRIVER_CAPABILITIES = ‘compute,utility’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_JUPYTER_TOKEN = ”[/COLOR]
[COLOR=var(–ansi-red)]# LAST_FORCED_REBUILD = ‘20230825’[/COLOR]
[COLOR=var(–ansi-red)]# NV_NVPROF_DEV_PACKAGE = ‘cuda-nvprof-11-8=11.8.87-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNPP_PACKAGE = ‘libnpp-11-8=11.8.0.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_DEV_PACKAGE_NAME = ‘libnccl-dev’[/COLOR]
[COLOR=var(–ansi-red)]# TCLLIBPATH = ‘/usr/share/tcltk/tcllib1.20’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_DEV_VERSION = ‘11.11.3.6-1’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_KERNEL_MANAGER_PROXY_HOST = ‘172.28.0.12’[/COLOR]
[COLOR=var(–ansi-red)]# NVIDIA_PRODUCT_NAME = ‘CUDA’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_DEV_PACKAGE_NAME = ‘libcublas-dev-11-8’[/COLOR]
[COLOR=var(–ansi-red)]# USE_AUTH_EPHEM = ‘1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_CUDART_VERSION = ‘11.8.89-1’[/COLOR]
[COLOR=var(–ansi-red)]# HOME = ‘/root’[/COLOR]
[COLOR=var(–ansi-red)]# LANG = ‘en_US.UTF-8’[/COLOR]
[COLOR=var(–ansi-red)]# CUDA_VERSION = ‘11.8.0’[/COLOR]
[COLOR=var(–ansi-red)]# CLOUDSDK_CONFIG = ‘/content/.config’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_PACKAGE = ‘libcublas-11-8=11.11.3.6-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_NSIGHT_COMPUTE_DEV_PACKAGE = ‘cuda-nsight-compute-11-8=11.8.0-1’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_RELEASE_TAG = ‘release-colab_20230921-060057_RC00’[/COLOR]
[COLOR=var(–ansi-red)]# PYDEVD_USE_FRAME_EVAL = ‘NO’[/COLOR]
[COLOR=var(–ansi-red)]# KMP_TARGET_PORT = ‘9000’[/COLOR]
[COLOR=var(–ansi-red)]# CLICOLOR = ‘1’[/COLOR]
[COLOR=var(–ansi-red)]# KMP_EXTRA_ARGS = (‘–logtostderr –listen_host=172.28.0.12 –target_host=172.28.0.12 ‘
‘–tunnel_background_save_url=https://colab.research.google.com/tu…-3go7bsxamragc
‘–tunnel_background_save_delay=10s ‘
‘–tunnel_periodic_background_save_frequency=30m0s ‘
‘–enable_output_coalescing=true –output_coalescing_required=true’)
[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNPP_DEV_PACKAGE = ‘libnpp-dev-11-8=11.8.0.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUBLAS_PACKAGE_NAME = ‘libcublas-11-8’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_KERNEL_MANAGER_PROXY_PORT = ‘6000’[/COLOR]
[COLOR=var(–ansi-red)]# CLOUDSDK_PYTHON = ‘python3’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNPP_DEV_VERSION = ‘11.8.0.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# ENABLE_DIRECTORYPREFETCHER = ‘1’[/COLOR]
[COLOR=var(–ansi-red)]# NO_GCE_CHECK = ‘False’[/COLOR]
[COLOR=var(–ansi-red)]# JPY_PARENT_PID = ’79’[/COLOR]
[COLOR=var(–ansi-red)]# PYTHONPATH = ‘/env/python’[/COLOR]
[COLOR=var(–ansi-red)]# TERM = ‘xterm-color’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBCUSPARSE_DEV_VERSION = ‘11.7.5.86-1’[/COLOR]
[COLOR=var(–ansi-red)]# GIT_PAGER = ‘cat’[/COLOR]
[COLOR=var(–ansi-red)]# LIBRARY_PATH = ‘/usr/local/cuda/lib64/stubs’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDNN_VERSION = ‘8.9.0.131’[/COLOR]
[COLOR=var(–ansi-red)]# SHLVL = ‘0’[/COLOR]
[COLOR=var(–ansi-red)]# PAGER = ‘cat’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_LANGUAGE_SERVER_PROXY = ‘/usr/colab/bin/language_service’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_LIB_VERSION = ‘11.8.0-1’[/COLOR]
[COLOR=var(–ansi-red)]# NVARCH = ‘x86_64’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDNN_PACKAGE_DEV = ‘libcudnn8-dev=8.9.0.131-1+cuda11.8’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_COMPAT_PACKAGE = ‘cuda-compat-11-8’[/COLOR]
[COLOR=var(–ansi-red)]# MPLBACKEND = ‘module://ipykernel.pylab.backend_inline’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_PACKAGE = ‘libnccl2=2.15.5-1+cuda11.8’[/COLOR]
[COLOR=var(–ansi-red)]# LD_LIBRARY_PATH = ‘/usr/local/nvidia/lib:/usr/local/nvidia/lib64’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_GPU = ”[/COLOR]
[COLOR=var(–ansi-red)]# GCS_READ_CACHE_BLOCK_SIZE_MB = ’16’[/COLOR]
[COLOR=var(–ansi-red)]# NV_CUDA_NSIGHT_COMPUTE_VERSION = ‘11.8.0-1’[/COLOR]
[COLOR=var(–ansi-red)]# NV_NVPROF_VERSION = ‘11.8.87-1’[/COLOR]
[COLOR=var(–ansi-red)]# LC_ALL = ‘en_US.UTF-8’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_FILE_HANDLER_ADDR = ‘localhost:3453’[/COLOR]
[COLOR=var(–ansi-red)]# PATH = ‘/root/.buildozer/android/platform/apache-ant-1.9.4/bin:/opt/bin:/usr/local/nvidia/bin:/usr/local/cuda/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/tools/node/bin:/tools/google-cloud-sdk/bin’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_PACKAGE_NAME = ‘libnccl2’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_DEBUG_ADAPTER_MUX_PATH = ‘/usr/local/bin/dap_multiplexer’[/COLOR]
[COLOR=var(–ansi-red)]# NV_LIBNCCL_PACKAGE_VERSION = ‘2.15.5-1’[/COLOR]
[COLOR=var(–ansi-red)]# PYTHONWARNINGS = ‘ignore:::pip._internal.cli.base_command’[/COLOR]
[COLOR=var(–ansi-red)]# DEBIAN_FRONTEND = ‘noninteractive’[/COLOR]
[COLOR=var(–ansi-red)]# COLAB_BACKEND_VERSION = ‘next’[/COLOR]
[COLOR=var(–ansi-red)]# OLDPWD = ‘/’[/COLOR]
[COLOR=var(–ansi-red)]# _ = ‘/usr/local/bin/buildozer’[/COLOR]
[COLOR=var(–ansi-red)]# PACKAGES_PATH = ‘/root/.buildozer/android/packages’[/COLOR]
[COLOR=var(–ansi-red)]# ANDROIDSDK = ‘/root/.buildozer/android/platform/android-sdk’[/COLOR]
[COLOR=var(–ansi-red)]# ANDROIDNDK = ‘/root/.buildozer/android/platform/android-ndk-r25b’[/COLOR]
[COLOR=var(–ansi-red)]# ANDROIDAPI = ’31’[/COLOR]
[COLOR=var(–ansi-red)]# ANDROIDMINAPI = ’21’[/COLOR]
[COLOR=var(–ansi-red)]# [/COLOR]
[COLOR=var(–ansi-red)]# Buildozer failed to execute the last command[/COLOR]
[COLOR=var(–ansi-red)]# The error might be hidden in the log above this error[/COLOR]
[COLOR=var(–ansi-red)]# Please read the full log, and search for it before[/COLOR]
[COLOR=var(–ansi-red)]# raising an issue with buildozer itself.[/COLOR]
[COLOR=var(–ansi-red)]# In case of a bug report, please add a full log with log_level = 2 و هم دلیل و رفع این ارور هم بگید و چجوری پوشه همراه هم باهاش apk کنم
و این برنامه رو با kivymd نوشتم دو تا فایل هست یکی با فرمت kv که داخلش کد های دکمه ها تکست اینپوت تکست ها و غیره هست و یک فرمت با فایل py که کد اصلی است و یک پوشه ی همراه
ممنون

در حال بررسی 0
shiba14 7 ماه 1 پاسخ 155 دیده شده 0

پاسخ ( ۱ )

  1. سلام پیشنهاد میکنم ورژن برنامه را:

    ۳۰٫۰٫۰

    بگذارید

ارسال یک پاسخ